Unable to Install Qsimcirq on Linux

Hi, one of my projects involves using qsimcirq plugin to simulate pennylane circuit algorithms and thus I am trying to install qsimcirq based on the instruction (https://github.com/quantumlib/qsim/blob/master/docs/install_qsimcirq.md). However, I keep getting this error message:

Could you help me on solving this error?

Hi @Leeseok_Kim!

Based on the error message,

error: could not find git for clone of pybind11-populate 

it sounds like git is not installed. Depending on the linux distribution you are using, you may have to look up the instructions for getting git installed.

If you are using Ubuntu, then sudo apt install git should help :slight_smile:

Thank you @josh!

I successfully installed the qsimcirq, but I’m having trouble in setting up the pennylane device with ‘cirq.qsim’.

Is there anything I am missing?

@Leeseok_Kim could you post the output of qml.about()?

If you are using a Jupyter notebook session, sometimes you need to restart the kernel for new devices to appear :slight_smile:

Hi, I restarted my kernel several times and it’s still not working. Also, my pennylane settings seem alright. Here’s the output of qml.about():

Hi @Leeseok_Kim, have you also installed the pennylane-cirq plugin? It doesn’t seem to be appearing in the screenshot above. You can do so via pip:

pip install pennylane-cirq

Hi @josh, it began to work after I restarted my computer. I guess it was my kernel problem. Thank you so much!

1 Like

Hi @Leeseok_Kim. I’m glad it worked out. Let us know if you have any more issues or questions!