Issues with simple QNN KerasLayer

While running the beautiful qnn + tf.keras demo, I tried scaling the quantum circuit from 2 qubits to 10, and it worked for 2…7, but started erroring out on at 8 qubits. Code is 99% same as the demo, only few lines changed to make the num_qubits 8 instead of 2:

import tensorflow as tf
import pennylane as qml
import matplotlib.pyplot as plt
import numpy as np
from sklearn.datasets import make_moons

# Set random seeds

X, y = make_moons(n_samples=200, noise=0.1)
y_hot = tf.keras.utils.to_categorical(y, num_classes=2)  # one-hot encoded labels

c = ["#1f77b4" if y_ == 0 else "#ff7f0e" for y_ in y]  # colours for each class
plt.scatter(X[:, 0], X[:, 1], c=c)

n_qubits = 8 # works for 2, 3, 4, ...7
dev = qml.device("default.qubit", wires=n_qubits)

def qnode(inputs, weights):
    qml.AngleEmbedding(inputs, wires=range(n_qubits))
    qml.BasicEntanglerLayers(weights, wires=range(n_qubits))
    return [qml.expval(qml.PauliZ(wires=i)) for i in range(n_qubits)]

n_layers = 6
weight_shapes = {"weights": (n_layers, n_qubits)}
qlayer = qml.qnn.KerasLayer(qnode, weight_shapes, output_dim=n_qubits)

clayer_1 = tf.keras.layers.Dense(n_qubits)
clayer_2 = tf.keras.layers.Dense(2, activation="softmax")
model = tf.keras.models.Sequential([clayer_1, qlayer, clayer_2])

opt = tf.keras.optimizers.SGD(learning_rate=0.02)
model.compile(opt, loss="mae", metrics=["accuracy"])

fitting =, y_hot, epochs=1, batch_size=50, validation_split=0.5, verbose=1)

And the error I get is:

InvalidArgumentError: Exception encountered when calling layer 'keras_layer' (type KerasLayer).

{{function_node __wrapped__MatMul_device_/job:localhost/replica:0/task:0/device:GPU:0}} Matrix size-incompatible: In[0]: [4,4], In[1]: [100,128] [Op:MatMul] name: 

Call arguments received by layer 'keras_layer' (type KerasLayer):
  • inputs=tf.Tensor(shape=(50, 8), dtype=float32)

The versions I am using are:

tf = 2.15.0
pennylane = 0.33.1

Hey @Hayk_Tepanyan!

We’ve made some updates to the tensorflow interface that aren’t formally released yet, but you can access these changes by installing PennyLane from source :slight_smile:

I’d make a new virtual environment and then install PennyLane from source like so:

git clone
cd pennylane
python -m pip install -e .

Your code should work after that (at least it did for me :grin:). Here’s my info:

Name: PennyLane
Version: 0.34.0.dev0
Summary: PennyLane is a Python quantum machine learning library by Xanadu Inc.
License: Apache License 2.0
Location: /Users/isaac/.virtualenvs/pennylane-source/lib/python3.9/site-packages
Editable project location: /Users/isaac/Documents/pennylane
Requires: appdirs, autograd, autoray, cachetools, networkx, numpy, pennylane-lightning, requests, rustworkx, scipy, semantic-version, toml, typing-extensions
Required-by: PennyLane-Lightning, PennyLane-qiskit

Platform info:           macOS-14.1.2-x86_64-i386-64bit
Python version:          3.9.14
Numpy version:           1.23.5
Scipy version:           1.11.2
Installed devices:
- default.gaussian (PennyLane-0.34.0.dev0)
- default.mixed (PennyLane-0.34.0.dev0)
- default.qubit (PennyLane-0.34.0.dev0)
- default.qubit.autograd (PennyLane-0.34.0.dev0)
- default.qubit.jax (PennyLane-0.34.0.dev0)
- default.qubit.legacy (PennyLane-0.34.0.dev0)
- (PennyLane-0.34.0.dev0)
- default.qubit.torch (PennyLane-0.34.0.dev0)
- qiskit.ibmq.circuit_runner (PennyLane-qiskit-0.32.0)
- qiskit.ibmq.sampler (PennyLane-qiskit-0.32.0)
- qiskit.remote (PennyLane-qiskit-0.32.0)
- lightning.qubit (PennyLane-Lightning-0.33.1)

and tensorflow version is 2.12.0.