Error installing catalyst

Hi,
I am trying to install Catalyst but having problem with the jaxlib version. The error that I am having is

Collecting pennylane-catalyst
  Using cached pennylane_catalyst-0.1.2-py3-none-manylinux2014_x86_64.whl (62.6 MB)
Requirement already satisfied: pennylane>=0.28 in /work/acslab/users/baobach/anaconda3/envs/lightning/lib/python3.12/site-packages (from pennylane-catalyst) (0.34.0)
Requirement already satisfied: jax==0.4.1 in /work/acslab/users/baobach/anaconda3/envs/lightning/lib/python3.12/site-packages (from pennylane-catalyst) (0.4.1)
INFO: pip is looking at multiple versions of pennylane-catalyst to determine which version is compatible with other requirements. This could take a while.
  Using cached pennylane_catalyst-0.1.1-py3-none-manylinux2014_x86_64.whl (61.4 MB)
  Using cached pennylane_catalyst-0.1.0-py3-none-manylinux2014_x86_64.whl (61.4 MB)
ERROR: Cannot install pennylane-catalyst==0.1.0, pennylane-catalyst==0.1.1 and pennylane-catalyst==0.1.2 because these package versions have conflicting dependencies.

The conflict is caused by:
    pennylane-catalyst 0.1.2 depends on jaxlib==0.4.1
    pennylane-catalyst 0.1.1 depends on jaxlib==0.4.1
    pennylane-catalyst 0.1.0 depends on jaxlib==0.4.1

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/topics/dependency-resolution/#dealing-with-dependency-conflicts
Note: you may need to restart the kernel to use updated packages.

I have tried reinstall jax==0.4.1 but it’s not working. Moreover, I can not directly install jaxlib==0.4.1 through pip install.
Below is my pennylane version

Name: PennyLane
Version: 0.34.0
Summary: PennyLane is a Python quantum machine learning library by Xanadu Inc.
Home-page: https://github.com/PennyLaneAI/pennylane
Author: 
Author-email: 
License: Apache License 2.0
Location: /work/acslab/users/baobach/anaconda3/envs/lightning/lib/python3.12/site-packages
Requires: appdirs, autograd, autoray, cachetools, networkx, numpy, pennylane-lightning, requests, rustworkx, scipy, semantic-version, toml, typing-extensions
Required-by: PennyLane-Lightning

Platform info:           Linux-3.10.0-957.27.2.el7.x86_64-x86_64-with-glibc2.17
Python version:          3.12.0
Numpy version:           1.26.3
Scipy version:           1.12.0
Installed devices:
- lightning.qubit (PennyLane-Lightning-0.34.0)
- default.gaussian (PennyLane-0.34.0)
- default.mixed (PennyLane-0.34.0)
- default.qubit (PennyLane-0.34.0)
- default.qubit.autograd (PennyLane-0.34.0)
- default.qubit.jax (PennyLane-0.34.0)
- default.qubit.legacy (PennyLane-0.34.0)
- default.qubit.tf (PennyLane-0.34.0)
- default.qubit.torch (PennyLane-0.34.0)
- default.qutrit (PennyLane-0.34.0)
- null.qubit (PennyLane-0.34.0)

Hi @Bach_Bao! Unfortunately Catalyst currently depends on TensorFlow, and TensorFlow does not support Python 3.12 – so we are unable to support Catalyst on Python 3.12 yet (but it’s something we are working on!).

In the meantime, if you are able to use Python versions 3.9-3.11, all of these should work with Catalyst.

1 Like